Vulnerability · Published Feb 2, 2024 · Assigned by GitHub_M

CVE-2024-23831Privilege escalation through CSRF attack on 'setup.pl'

High 7.5

In plain English

A high-severity cross-site request forgery in LedgerSMB from ledgersmb. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.3% (higher than 20% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)7.5High
Exploit odds (30 days)0.3%top 80.1% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

LedgerSMB is a free web-based double-entry accounting system. When a LedgerSMB database administrator has an active session in /setup.pl, an attacker can trick the admin into clicking on a link which automatically submits a request to setup.pl without the admin's consent. This request can be used to create a new user account with full application (/login.pl) privileges, leading to privilege escalation. The vulnerability is patched in versions 1.10.30 and 1.11.9.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Debian:12ledgersmbno fix listedDEBIAN-CVE-2024-23831
Ubuntu:22.04:LTSledgersmb1.6.33+ds-1ubuntu0.1USN-7647-1
Ubuntu:22.04:LTSledgersmb1.6.33+ds-1ubuntu0.1UBUNTU-CVE-2024-23831
Ubuntu:24.04:LTSledgersmb1.6.33+ds-2.1ubuntu0.1USN-7647-1
Ubuntu:24.04:LTSledgersmb1.6.33+ds-2.1ubuntu0.1UBUNTU-CVE-2024-23831

Affected products (as reported)

VendorProductVersions
ledgersmb LedgerSMB < 1.10.30>= 1.11.0, < 1.11.9

Weakness: CWE-352 · Vector: CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:H

References