Vulnerability · Published Mar 13, 2024 · Assigned by apache

CVE-2024-23672Apache Tomcat: WebSocket DoS with incomplete closing handshake

Medium 6.3

In plain English

A medium-severity security flaw in Apache Tomcat from Apache Software Foundation. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 2.3% (higher than 83% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)6.3Medium
Exploit odds (30 days)2.3%top 16.5% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

Denial of Service via incomplete cleanup vulnerability in Apache Tomcat. It was possible for WebSocket clients to keep WebSocket connections open leading to increased resource consumption.This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.0-M16, from 10.1.0-M1 through 10.1.18, from 9.0.0-M1 through 9.0.85, from 8.5.0 through 8.5.98. Older, EOL versions may also be affected. Users are recommended to upgrade to version 11.0.0-M17, 10.1.19, 9.0.86 or 8.5.99 which fix the issue.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
AlmaLinux:8tomcat1:9.0.87-1.el8_10.1.alma.1ALSA-2024:3666
AlmaLinux:9tomcat1:9.0.87-1.el9_4.1ALSA-2024:3307
AlmaLinux:8tomcat-admin-webapps1:9.0.87-1.el8_10.1.alma.1ALSA-2024:3666
AlmaLinux:9tomcat-admin-webapps1:9.0.87-1.el9_4.1ALSA-2024:3307
AlmaLinux:8tomcat-docs-webapp1:9.0.87-1.el8_10.1.alma.1ALSA-2024:3666
AlmaLinux:9tomcat-docs-webapp1:9.0.87-1.el9_4.1ALSA-2024:3307
AlmaLinux:8tomcat-el-3.0-api1:9.0.87-1.el8_10.1.alma.1ALSA-2024:3666
AlmaLinux:9tomcat-el-3.0-api1:9.0.87-1.el9_4.1ALSA-2024:3307
AlmaLinux:8tomcat-jsp-2.3-api1:9.0.87-1.el8_10.1.alma.1ALSA-2024:3666
AlmaLinux:9tomcat-jsp-2.3-api1:9.0.87-1.el9_4.1ALSA-2024:3307
AlmaLinux:8tomcat-lib1:9.0.87-1.el8_10.1.alma.1ALSA-2024:3666
AlmaLinux:9tomcat-lib1:9.0.87-1.el9_4.1ALSA-2024:3307
AlmaLinux:8tomcat-servlet-4.0-api1:9.0.87-1.el8_10.1.alma.1ALSA-2024:3666
AlmaLinux:9tomcat-servlet-4.0-api1:9.0.87-1.el9_4.1ALSA-2024:3307
AlmaLinux:8tomcat-webapps1:9.0.87-1.el8_10.1.alma.1ALSA-2024:3666
AlmaLinux:9tomcat-webapps1:9.0.87-1.el9_4.1ALSA-2024:3307
Debian:12tomcat1010.1.6-1+deb12u2DEBIAN-CVE-2024-23672
Debian:12tomcat1010.1.6-1+deb12u2DSA-5665-1
Debian:13tomcat1010.1.20-1DEBIAN-CVE-2024-23672
Debian:14tomcat1010.1.20-1DEBIAN-CVE-2024-23672
Debian:12tomcat99.0.70-2DEBIAN-CVE-2024-23672
Debian:13tomcat99.0.70-2DEBIAN-CVE-2024-23672
Debian:14tomcat99.0.70-2DEBIAN-CVE-2024-23672
Mavenorg.apache.tomcat.embed:tomcat-embed-websocket10.1.19GHSA-v682-8vv8-vpwr
Mavenorg.apache.tomcat.embed:tomcat-embed-websocket9.0.86GHSA-v682-8vv8-vpwr
Mavenorg.apache.tomcat.embed:tomcat-embed-websocket8.5.99GHSA-v682-8vv8-vpwr
Mavenorg.apache.tomcat.embed:tomcat-embed-websocket11.0.0-M17GHSA-v682-8vv8-vpwr
Mavenorg.apache.tomcat:tomcat-websocket9.0.86GHSA-v682-8vv8-vpwr
Mavenorg.apache.tomcat:tomcat-websocket10.1.19GHSA-v682-8vv8-vpwr
Mavenorg.apache.tomcat:tomcat-websocket11.0.0-M17GHSA-v682-8vv8-vpwr
Mavenorg.apache.tomcat:tomcat-websocket8.5.99GHSA-v682-8vv8-vpwr
Rocky Linux:8tomcat1:9.0.87-1.el8_10.1RLSA-2024:3666
Rocky Linux:9tomcat1:9.0.87-1.el9_4.1RLSA-2024:3307
Ubuntu:25.10tomcat99.0.70-2ubuntu3UBUNTU-CVE-2024-23672

Affected products (as reported)

VendorProductVersions
Apache Software Foundation Apache Tomcat 11.0.0-M1 – through 11.0.0-M1610.1.0-M1 – through 10.1.189.0.0-M1 – through 9.0.858.5.0 – through 8.5.98

Weakness: CWE-459 · Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:L

References