Vulnerability · Published Jan 23, 2024 · Assigned by GitHub_M

CVE-2024-23638SQUID-2023:11 Denial of Service in Cache Manager

Medium 6.5

In plain English

A medium-severity security flaw in squid from squid-cache. Proof-of-concept exploit code is public. The chance it is exploited in the next 30 days is estimated at 60.1% (higher than 99.1% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)6.5Medium
Exploit odds (30 days)60.1%top 0.9% of all CVEs
Exploited in the wildNo reportsCISA SSVC: poc
Attack toolingNoneno public tooling known

Official description

Squid is a caching proxy for the Web. Due to an expired pointer reference bug, Squid prior to version 6.6 is vulnerable to a Denial of Service attack against Cache Manager error responses. This problem allows a trusted client to perform Denial of Service when generating error pages for Client Manager reports. Squid older than 5.0.5 have not been tested and should be assumed to be vulnerable. All Squid-5.x up to and including 5.9 are vulnerable. All Squid-6.x up to and including 6.5 are vulnerable. This bug is fixed by Squid version 6.6. In addition, patches addressing this problem for the stable releases can be found in Squid's patch archives. As a workaround, prevent access to Cache Manager using Squid's main access control: `http_access deny manager`.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
AlmaLinux:8libecap1.0.1-2.module_el8.6.0+2741+01592ae8ALSA-2024:9644
AlmaLinux:8libecap1.0.1-2.module_el8.6.0+3048+383bc947ALSA-2024:9644
AlmaLinux:8libecap-devel1.0.1-2.module_el8.6.0+2741+01592ae8ALSA-2024:9644
AlmaLinux:8libecap-devel1.0.1-2.module_el8.6.0+3048+383bc947ALSA-2024:9644
AlmaLinux:8squid7:4.15-10.module_el8.10.0+3916+ed00a4a0.3ALSA-2024:9644
AlmaLinux:9squid7:5.5-13.el9_4ALSA-2024:4861
Debian:12squid5.7-2+deb12u1DEBIAN-CVE-2024-23638
Debian:12squid5.7-2+deb12u1DSA-5637-1
Debian:13squid6.6-1DEBIAN-CVE-2024-23638
Debian:14squid6.6-1DEBIAN-CVE-2024-23638
Rocky Linux:8libecap0:1.0.1-2.module+el8.9.0+1437+df5ea8f0RLSA-2024:9644
Rocky Linux:8squid7:4.15-10.module+el8.10.0+1758+80ba9f4bRLSA-2024:9644
Rocky Linux:9squid7:5.5-13.el9_4RLSA-2024:4861
Ubuntu:22.04:LTSsquid5.7-0ubuntu0.22.04.4USN-6728-1
Ubuntu:22.04:LTSsquid5.7-0ubuntu0.22.04.4UBUNTU-CVE-2024-23638

Affected products (as reported)

VendorProductVersions
squid-cache squid < 6.6

Weakness: CWE-825 · Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H

References