Vulnerability · Published Feb 2, 2024 · Assigned by GitHub_M

CVE-2024-23635AntiSamy malicious input can provoke XSS when preserving comments

Medium 6.1

In plain English

A medium-severity cross-site scripting in antisamy from nahsra. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.4% (higher than 31% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)6.1Medium
Exploit odds (30 days)0.4%top 69.2% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

AntiSamy is a library for performing fast, configurable cleansing of HTML coming from untrusted sources. Prior to 1.7.5, there is a potential for a mutation XSS (mXSS) vulnerability in AntiSamy caused by flawed parsing of the HTML being sanitized. To be subject to this vulnerability the `preserveComments` directive must be enabled in your policy file. As a result, certain crafty inputs can result in elements in comment tags being interpreted as executable when using AntiSamy's sanitized output. Patched in AntiSamy 1.7.5 and later.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Debian:12libowasp-antisamy-javano fix listedDEBIAN-CVE-2024-23635
Debian:13libowasp-antisamy-javano fix listedDEBIAN-CVE-2024-23635
Debian:14libowasp-antisamy-java1.7.8-1DEBIAN-CVE-2024-23635
Mavenorg.owasp.antisamy:antisamy1.7.5GHSA-2mrq-w8pv-5pvq
Ubuntu:22.04:LTSlibowasp-antisamy-javano fix listedUBUNTU-CVE-2024-23635
Ubuntu:24.04:LTSlibowasp-antisamy-javano fix listedUBUNTU-CVE-2024-23635
Ubuntu:25.10libowasp-antisamy-javano fix listedUBUNTU-CVE-2024-23635
Ubuntu:26.04:LTSlibowasp-antisamy-javano fix listedUBUNTU-CVE-2024-23635
Ubuntu:26.10libowasp-antisamy-javano fix listedUBUNTU-CVE-2024-23635

Affected products (as reported)

VendorProductVersions
nahsra antisamy < 1.7.5

Weakness: CWE-79 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N

References