Vulnerability · Published Feb 22, 2024 · Assigned by apache
CVE-2024-23349Apache Answer: XSS vulnerability when submitting summary
Medium 5.4
In plain English
A medium-severity cross-site scripting in Apache Answer from Apache Software Foundation. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 1.1% (higher than 65% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Apache Answer.This issue affects Apache Answer: through 1.2.1. XSS attack when user enters summary. A logged-in user, when modifying their own submitted question, can input malicious code in the summary to create such an attack. Users are recommended to upgrade to version [1.2.5], which fixes the issue.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Go | github.com/apache/incubator-answer | 1.2.5 | GHSA-8pf2-qj4v-fj64 |
| Go | github.com/apache/incubator-answer | 1.2.5 | GO-2024-2578 |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| Apache Software Foundation | Apache Answer | 0 – through 1.2.1 |
Weakness: CWE-79 · Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N