Vulnerability · Published Feb 23, 2024 · Assigned by apache
CVE-2024-23320Apache DolphinScheduler: Arbitrary js execution as root for authenticated users
High 8.8
In plain English
A high-severity improper input validation in Apache DolphinScheduler from Apache Software Foundation. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 1.4% (higher than 72% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
Improper Input Validation vulnerability in Apache DolphinScheduler. An authenticated user can cause arbitrary, unsandboxed javascript to be executed on the server. This issue is a legacy of CVE-2023-49299. We didn't fix it completely in CVE-2023-49299, and we added one more patch to fix it. This issue affects Apache DolphinScheduler: until 3.2.1. Users are recommended to upgrade to version 3.2.1, which fixes the issue.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Maven | org.apache.dolphinscheduler:dolphinscheduler-master | 3.2.1 | GHSA-rc6h-qwj9-2c53 |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| Apache Software Foundation | Apache DolphinScheduler | 0 – before 3.2.1 |
Weakness: CWE-20 · Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
References
- https://github.com/apache/dolphinscheduler/pull/15487 patch
- https://lists.apache.org/thread/tnf99qoc6tlnwrny4t1zk6mfszgdsokm issue-tracking
- https://lists.apache.org/thread/25qhfvlksozzp6j9y8ozznvjdjp3lxqq vendor-advisory
- https://lists.apache.org/thread/p7rwzdgrztdfps8x1bwx646f1mn0x6cp vendor-advisory
- http://www.openwall.com/lists/oss-security/2024/02/23/3