Vulnerability · Published Mar 8, 2024 · Assigned by apple

CVE-2024-23280

High 7.5

In plain English

A high-severity security flaw in iOS and iPadOS from Apple. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 1.3% (higher than 70% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)7.5High
Exploit odds (30 days)1.3%top 29.9% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

An injection issue was addressed with improved validation. This issue is fixed in Safari 17.4, iOS 17.4 and iPadOS 17.4, macOS Sonoma 14.4, tvOS 17.4, watchOS 10.4. A maliciously crafted webpage may be able to fingerprint the user.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
AlmaLinux:8webkit2gtk32.46.3-2.el8_10ALSA-2024:10481
AlmaLinux:8webkit2gtk3-devel2.46.3-2.el8_10ALSA-2024:10481
AlmaLinux:8webkit2gtk3-jsc2.46.3-2.el8_10ALSA-2024:10481
AlmaLinux:8webkit2gtk3-jsc-devel2.46.3-2.el8_10ALSA-2024:10481
Debian:12webkit2gtk2.44.1-1~deb12u1DSA-5684-1
Debian:12webkit2gtk2.44.1-1~deb12u1DEBIAN-CVE-2024-23280
Debian:13webkit2gtk2.44.0-1DEBIAN-CVE-2024-23280
Debian:14webkit2gtk2.44.0-1DEBIAN-CVE-2024-23280
Debian:12wpewebkitno fix listedDEBIAN-CVE-2024-23280
Debian:13wpewebkit2.44.1-1DEBIAN-CVE-2024-23280
Debian:14wpewebkit2.44.1-1DEBIAN-CVE-2024-23280
Ubuntu:22.04:LTSqtwebkit-opensource-srcno fix listedUBUNTU-CVE-2024-23280
Ubuntu:24.04:LTSqtwebkit-opensource-srcno fix listedUBUNTU-CVE-2024-23280
Ubuntu:22.04:LTSwebkit2gtk2.44.0-0ubuntu0.22.04.1USN-6732-1
Ubuntu:22.04:LTSwebkit2gtk2.44.0-0ubuntu0.22.04.1UBUNTU-CVE-2024-23280
Ubuntu:22.04:LTSwpewebkitno fix listedUBUNTU-CVE-2024-23280

Affected products (as reported)

VendorProductVersions
Apple Safari 0 – before 17.4
Apple iOS and iPadOS 0 – before 17.4
Apple macOS 0 – before 14.4
Apple tvOS 0 – before 17.4
Apple watchOS 0 – before 10.4

References