Actively exploited · Published Jan 23, 2024 · Assigned by apple

CVE-2024-23222

High 8.8 Exploited

In plain English

A high-severity type confusion in iOS and iPadOS from Apple. Attackers are actively exploiting it in the wild (listed by CISA on January 23, 2024). The chance it is exploited in the next 30 days is estimated at 10.6% (higher than 96% of all known vulnerabilities). Ready-made attack tooling exists: public proof-of-concept code. Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)8.8High
Exploit odds (30 days)10.6%top 4.2% of all CVEs
Exploited in the wildYesCISA KEV since Jan 23, 2024
Attack tooling1Public PoC

CISA guidance

Apply mitigations per vendor instructions or discontinue use of the product if mitigations are unavailable.

Federal agencies must remediate by Feb 13, 2024.

Official description

A type confusion issue was addressed with improved checks. This issue is fixed in Safari 17.3, iOS 15.8.7 and iPadOS 15.8.7, iOS 16.7.5 and iPadOS 16.7.5, iOS 17.3 and iPadOS 17.3, macOS Monterey 12.7.3, macOS Sonoma 14.3, macOS Ventura 13.6.4, tvOS 17.3, visionOS 1.0.2. Processing maliciously crafted web content may lead to arbitrary code execution. This fix associated with the Coruna exploit was shipped in iOS 17.3 on January 22, 2024. This update brings that fix to devices that cannot update to the latest iOS version.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Debian:12webkit2gtk2.42.5-1~deb12u1DSA-5618-1
Debian:12webkit2gtk2.42.5-1~deb12u1DEBIAN-CVE-2024-23222
Debian:13webkit2gtk2.42.5-1DEBIAN-CVE-2024-23222
Debian:14webkit2gtk2.42.5-1DEBIAN-CVE-2024-23222
Debian:12wpewebkitno fix listedDEBIAN-CVE-2024-23222
Debian:13wpewebkit2.42.5-1DEBIAN-CVE-2024-23222
Debian:14wpewebkit2.42.5-1DEBIAN-CVE-2024-23222
Ubuntu:22.04:LTSqtwebkit-opensource-srcno fix listedUBUNTU-CVE-2024-23222
Ubuntu:24.04:LTSqtwebkit-opensource-srcno fix listedUBUNTU-CVE-2024-23222
Ubuntu:22.04:LTSwebkit2gtk2.42.5-0ubuntu0.22.04.2UBUNTU-CVE-2024-23222
Ubuntu:22.04:LTSwebkit2gtk2.42.5-0ubuntu0.22.04.2USN-6631-1
Ubuntu:22.04:LTSwpewebkitno fix listedUBUNTU-CVE-2024-23222

Affected products (as reported)

VendorProductVersions
Apple Safari 0 – before 17.3
Apple iOS and iPadOS 0 – before 15.8.70 – before 16.7.50 – before 17.3
Apple macOS 0 – before 12.7.30 – before 13.6.40 – before 14.3
Apple tvOS 0 – before 17.3
Apple visionOS 0 – before 1.0.2

Weakness: CWE-843 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

References