Vulnerability · Published Feb 20, 2024 · Assigned by apache
CVE-2024-23114Apache Camel: Camel-CassandraQL: Unsafe Deserialization from CassandraAggregationRepository
Critical 9.8
In plain English
A critical-severity unsafe deserialization in Apache Camel from Apache Software Foundation. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 1.3% (higher than 70% of all known vulnerabilities). Ready-made attack tooling exists: public proof-of-concept code. Fixed versions are available - upgrade the affected package.
Official description
Deserialization of Untrusted Data vulnerability in Apache Camel CassandraQL Component AggregationRepository which is vulnerable to unsafe deserialization. Under specific conditions it is possible to deserialize malicious payload.This issue affects Apache Camel: from 3.0.0 before 3.21.4, from 3.22.0 before 3.22.1, from 4.0.0 before 4.0.4, from 4.1.0 before 4.4.0. Users are recommended to upgrade to version 4.4.0, which fixes the issue. If users are on the 4.0.x LTS releases stream, then they are suggested to upgrade to 4.0.4. If users are on 3.x, they are suggested to move to 3.21.4 or 3.22.1
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Maven | org.apache.camel:camel-cassandraql | 3.21.4 | GHSA-m43p-55rf-8c2j |
| Maven | org.apache.camel:camel-cassandraql | 3.22.1 | GHSA-m43p-55rf-8c2j |
| Maven | org.apache.camel:camel-cassandraql | 4.0.4 | GHSA-m43p-55rf-8c2j |
| Maven | org.apache.camel:camel-cassandraql | 4.4.0 | GHSA-m43p-55rf-8c2j |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| Apache Software Foundation | Apache Camel | 3.0.0 – before 3.21.43.22.0 – before 3.22.14.0.0 – before 4.0.44.1.0 – before 4.4.0 |
Weakness: CWE-502 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
References
- https://camel.apache.org/security/CVE-2024-23114.html vendor-advisory