Vulnerability · Published Apr 9, 2024 · Assigned by GitHub_M

CVE-2024-22423yt-dlp `--exec` command injection when using `%q` in yt-dlp on Windows

High 8.4

In plain English

A high-severity OS command injection in yt-dlp from yt-dlp. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 1.4% (higher than 73% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)8.4High
Exploit odds (30 days)1.4%top 26.9% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

yt-dlp is a youtube-dl fork with additional features and fixes. The patch that addressed CVE-2023-40581 attempted to prevent RCE when using `--exec` with `%q` by replacing double quotes with two double quotes. However, this escaping is not sufficient, and still allows expansion of environment variables. Support for output template expansion in `--exec`, along with this vulnerable behavior, was added to `yt-dlp` in version 2021.04.11. yt-dlp version 2024.04.09 fixes this issue by properly escaping `%`. It replaces them with `%%cd:~,%`, a variable that expands to nothing, leaving only the leading percent. It is recommended to upgrade yt-dlp to version 2024.04.09 as soon as possible. Also, always be careful when using `--exec`, because while this specific vulnerability has been patched, using unvalidated input in shell commands is inherently dangerous. For Windows users who are not able to upgrade, avoid using any output template expansion in `--exec` other than `{}` (filepath); if expansion in `--exec` is needed, verify the fields you are using do not contain `"`, `|` or `&`; and/or instead of using `--exec`, write the info json and load the fields from it instead.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Alpine:v3.20yt-dlp0-r0ALPINE-CVE-2024-22423
Alpine:v3.21yt-dlp0-r0ALPINE-CVE-2024-22423
Alpine:v3.22yt-dlp0-r0ALPINE-CVE-2024-22423
Alpine:v3.23yt-dlp0-r0ALPINE-CVE-2024-22423
Alpine:v3.24yt-dlp0-r0ALPINE-CVE-2024-22423
PyPIyt-dlp2024.04.09PYSEC-2026-2066
PyPIyt-dlp2024.04.09GHSA-hjq6-52gw-2g7p
Ubuntu:22.04:LTSyt-dlpno fix listedUBUNTU-CVE-2024-22423
Ubuntu:24.04:LTSyt-dlpno fix listedUBUNTU-CVE-2024-22423
Ubuntu:25.10yt-dlpno fix listedUBUNTU-CVE-2024-22423
Ubuntu:26.04:LTSyt-dlpno fix listedUBUNTU-CVE-2024-22423
Ubuntu:26.10yt-dlpno fix listedUBUNTU-CVE-2024-22423

Affected products (as reported)

VendorProductVersions
yt-dlp yt-dlp >= 2021.04.11, < 2024.04.09

Weakness: CWE-78 · Vector: CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:C/C:H/I:H/A:H

References