Vulnerability · Published Jan 18, 2024 · Assigned by GitHub_M
CVE-2024-22415Unsecured endpoints in the jupyter-lsp server extension
High 7.3
In plain English
A high-severity improper access control in jupyterlab-lsp from jupyter-lsp. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.5% (higher than 42% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
jupyter-lsp is a coding assistance tool for JupyterLab (code navigation + hover suggestions + linters + autocompletion + rename) using Language Server Protocol. Installations of jupyter-lsp running in environments without configured file system access control (on the operating system level), and with jupyter-server instances exposed to non-trusted network are vulnerable to unauthorised access and modification of file system beyond the jupyter root directory. This issue has been patched in version 2.2.2 and all users are advised to upgrade. Users unable to upgrade should uninstall jupyter-lsp.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| PyPI | jupyter-lsp | 2.2.2 | GHSA-4qhp-652w-c22x |
| PyPI | jupyter-lsp | 2.2.2 | PYSEC-2026-1478 |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| jupyter-lsp | jupyterlab-lsp | < 2.2.2 |
Weakness: CWE-23, CWE-284, CWE-306 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L