Vulnerability · Published Sep 16, 2024 · Assigned by apache
CVE-2024-22399Apache Seata: Remote Code Execution vulnerability via Hessian Deserialization in Apache Seata Server
Critical 9.8
In plain English
A critical-severity unsafe deserialization in Apache Seata from Apache Software Foundation. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 3.3% (higher than 89% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
Deserialization of Untrusted Data vulnerability in Apache Seata. When developers disable authentication on the Seata-Server and do not use the Seata client SDK dependencies, they may construct uncontrolled serialized malicious requests by directly sending bytecode based on the Seata private protocol. This issue affects Apache Seata: 2.0.0, from 1.0.0 through 1.8.0. Users are recommended to upgrade to version 2.1.0/1.8.1, which fixes the issue.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Maven | org.apache.seata:seata-core | 2.1.0 | GHSA-3xq2-w6j4-c99r |
| Maven | org.apache.seata:seata-core | 1.8.1 | GHSA-3xq2-w6j4-c99r |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| Apache Software Foundation | Apache Seata | 2.0.01.0.0 – through 1.8.0 |
Weakness: CWE-502 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H