Vulnerability · Published Feb 26, 2024 · Assigned by apache

CVE-2024-22371Apache Camel issue on ExchangeCreatedEvent

Low 2.9

In plain English

A low-severity security flaw in Apache Camel from Apache Software Foundation. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.7% (higher than 53% of all known vulnerabilities). Ready-made attack tooling exists: public proof-of-concept code. Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)2.9Low
Exploit odds (30 days)0.7%top 46.8% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack tooling1Public PoC

Official description

Exposure of sensitive data by by crafting a malicious EventFactory and providing a custom ExchangeCreatedEvent that exposes sensitive data. Vulnerability in Apache Camel.This issue affects Apache Camel: from 3.21.X through 3.21.3, from 3.22.X through 3.22.0, from 4.0.X through 4.0.3, from 4.X through 4.3.0. Users are recommended to upgrade to version 3.21.4, 3.22.1, 4.0.4 or 4.4.0, which fixes the issue.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Mavenorg.apache.camel:camel-core3.21.4GHSA-qpxm-689r-3849
Mavenorg.apache.camel:camel-core3.22.1GHSA-qpxm-689r-3849
Mavenorg.apache.camel:camel-core4.0.4GHSA-qpxm-689r-3849
Mavenorg.apache.camel:camel-core4.4.0GHSA-qpxm-689r-3849

Affected products (as reported)

VendorProductVersions
Apache Software Foundation Apache Camel 3.21.x – through 3.21.33.22.x – through 3.22.04.0.x – through 4.0.34.x – through 4.3.0

Weakness: CWE-922 · Vector: CVSS:3.1/AV:L/AC:H/PR:N/UI:N/S:U/C:L/I:N/A:N

References