Vulnerability · Published Jan 18, 2024 · Assigned by GitHub_M
CVE-2024-22213Cross-site Scripting when sending HTML as a comment in the Nextcloud Deck app
None 0.0
In plain English
A cross-site scripting in security-advisories from nextcloud. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.5% (higher than 43% of all known vulnerabilities).
Official description
Deck is a kanban style organization tool aimed at personal planning and project organization for teams integrated with Nextcloud. In affected versions users could be tricked into executing malicious code that would execute in their browser via HTML sent as a comment. It is recommended that the Nextcloud Deck is upgraded to version 1.9.5 or 1.11.2. There are no known workarounds for this vulnerability.
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| nextcloud | security-advisories | >= 1.9.0, < 1.9.5>= 1.10.0, < 1.11.2 |
Weakness: CWE-79 · Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:N
References
- https://github.com/nextcloud/security-advisories/security/advisories/GHSA-mg7w-x9fm-9wwc x_refsource_CONFIRM
- https://github.com/nextcloud/deck/commit/91f1557362047f8840f53151f176b80148650bcd x_refsource_MISC
- https://hackerone.com/reports/2058556 x_refsource_MISC