Vulnerability · Published Jun 6, 2024 · Assigned by @huntr_ai

CVE-2024-2213Improper Authentication in zenml-io/zenml

Low 3.3

In plain English

A low-severity security flaw in zenml-io/zenml from zenml-io. Proof-of-concept exploit code is public. The chance it is exploited in the next 30 days is estimated at 0.2% (higher than 16% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.0)3.3Low
Exploit odds (30 days)0.2%top 84.4% of all CVEs
Exploited in the wildNo reportsCISA SSVC: poc
Attack toolingNoneno public tooling known

Official description

An issue was discovered in zenml-io/zenml versions up to and including 0.55.4. Due to improper authentication mechanisms, an attacker with access to an active user session can change the account password without needing to know the current password. This vulnerability allows for unauthorized account takeover by bypassing the standard password change verification process. The issue was fixed in version 0.56.3.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
PyPIzenml0.56.3GHSA-j527-v579-m98h
PyPIzenml0.56.3PYSEC-2024-193

Affected products (as reported)

VendorProductVersions
zenml-io zenml-io/zenml unspecified – before 0.56.3

Weakness: CWE-620 · Vector: CVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:N

References