Vulnerability · Published Jan 19, 2024 · Assigned by apache

CVE-2024-21733Apache Tomcat: Leaking of unrelated request bodies in default error page

Medium 5.3

In plain English

A medium-severity security flaw in Apache Tomcat from Apache Software Foundation. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 14.3% (higher than 97% of all known vulnerabilities). Ready-made attack tooling exists: public proof-of-concept code. Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)5.3Medium
Exploit odds (30 days)14.3%top 3.4% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack tooling1Public PoC

Official description

Generation of Error Message Containing Sensitive Information vulnerability in Apache Tomcat.This issue affects Apache Tomcat: from 8.5.7 through 8.5.63, from 9.0.0-M11 through 9.0.43. Other, EOL versions may also be affected. Users are recommended to upgrade to version 8.5.64 onwards or 9.0.44 onwards, which contain a fix for the issue.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Debian:12tomcat99.0.53-1DEBIAN-CVE-2024-21733
Debian:13tomcat99.0.53-1DEBIAN-CVE-2024-21733
Debian:14tomcat99.0.53-1DEBIAN-CVE-2024-21733
Mavenorg.apache.tomcat.embed:tomcat-embed-core8.5.64GHSA-f4qf-m5gf-8jm8
Mavenorg.apache.tomcat.embed:tomcat-embed-core9.0.44GHSA-f4qf-m5gf-8jm8
Mavenorg.apache.tomcat.experimental:tomcat-embed-programmatic9.0.44GHSA-f4qf-m5gf-8jm8
Mavenorg.apache.tomcat:tomcat-coyote9.0.44GHSA-f4qf-m5gf-8jm8
Mavenorg.apache.tomcat:tomcat-coyote8.5.64GHSA-f4qf-m5gf-8jm8

Affected products (as reported)

VendorProductVersions
Apache Software Foundation Apache Tomcat 8.5.7 – through 8.5.639.0.0-M11 – through 9.0.43

Weakness: CWE-209 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N

References