Vulnerability · Published Jan 3, 2024 · Assigned by GitHub_M

CVE-2024-21622Craft CMS Privilege Escalation

Medium 5.4

In plain English

A medium-severity privilege mismanagement in cms from craftcms. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.6% (higher than 48% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)5.4Medium
Exploit odds (30 days)0.6%top 51.7% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

Craft is a content management system. This is a potential moderate impact, low complexity privilege escalation vulnerability in Craft starting in 3.x prior to 3.9.6 and 4.x prior to 4.4.16 with certain user permissions setups. This has been fixed in Craft 4.4.16 and Craft 3.9.6. Users should ensure they are running at least those versions.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Packagistcraftcms/cms4.5.11GHSA-j5g9-j7r4-6qvx
Packagistcraftcms/cms3.9.6GHSA-j5g9-j7r4-6qvx

Affected products (as reported)

VendorProductVersions
craftcms cms >= 4.0.0-RC1, < 4.5.11>= 3.0.0, < 3.9.6

Weakness: CWE-269 · Vector: CVSS:3.1/AV:A/AC:L/PR:L/UI:N/S:C/C:N/I:L/A:L

References