Vulnerability · Published Jun 6, 2024 · Assigned by @huntr_ai
CVE-2024-2032Race Condition Vulnerability in zenml-io/zenml
Low 3.1
In plain English
A low-severity security flaw in zenml-io/zenml from zenml-io. Proof-of-concept exploit code is public. The chance it is exploited in the next 30 days is estimated at 0.3% (higher than 22% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
A race condition vulnerability exists in zenml-io/zenml versions up to and including 0.55.3, which allows for the creation of multiple users with the same username when requests are sent in parallel. This issue was fixed in version 0.55.5. The vulnerability arises due to insufficient handling of concurrent user creation requests, leading to data inconsistencies and potential authentication problems. Specifically, concurrent processes may overwrite or corrupt user data, complicating user identification and posing security risks. This issue is particularly concerning for APIs that rely on usernames as input parameters, such as PUT /api/v1/users/test_race, where it could lead to further complications.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| PyPI | zenml | 0.55.5 | GHSA-c546-8jmq-hprj |
| PyPI | zenml | 0.55.5 | PYSEC-2024-105 |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| zenml-io | zenml-io/zenml | unspecified – before 0.55.5 |
Weakness: CWE-366 · Vector: CVSS:3.0/AV:N/AC:H/PR:H/UI:R/S:U/C:N/I:L/A:L