Vulnerability · Published Feb 26, 2024 · Assigned by LY-Corporation
CVE-2024-1735
Critical 9.1
In plain English
A critical-severity improper authentication in Armeria from LINE Corporation. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.8% (higher than 58% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Severity (CVSS 3.1)9.1Critical
Exploit odds (30 days)0.8%top 42.2% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known
Official description
A vulnerability has been identified in armeria-saml versions less than 1.27.2, allowing the use of malicious SAML messages to bypass authentication. All users who rely on armeria-saml older than version 1.27.2 must upgrade to 1.27.2 or later.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Maven | com.linecorp.armeria:armeria-saml | 1.27.2 | GHSA-4m6j-23p2-8c54 |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| LINE Corporation | Armeria | 0.69.0 – before 1.27.2 |
Weakness: CWE-287 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N