Vulnerability · Published Apr 9, 2024 · Assigned by Wordfence
CVE-2024-1412Memberpress <= 1.11.24 - Reflected Cross-Site Scripting via message and error
Medium 6.1
In plain English
A medium-severity cross-site scripting in Memberpress from MemberPress. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.5% (higher than 43% of all known vulnerabilities).
Official description
The Memberpress plugin for WordPress is vulnerable to Reflected Cross-Site Scripting via the ‘message’ and 'error' parameters in all versions up to, and including, 1.11.26 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that execute if they can successfully trick a user into performing an action such as clicking on a link. Note - the issue was partially patched in 1.11.25, but could still potentially be exploited under some circumstances.
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| MemberPress | Memberpress | 0 – through 1.11.26 |
Weakness: CWE-79 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N