Vulnerability · Published Mar 21, 2025 · Assigned by VulDB

CVE-2024-13903quickjs-ng QuickJS qjs quickjs.c JS_GetRuntime stack-based overflow

Medium 4.3

In plain English

A medium-severity stack buffer overflow in QuickJS from quickjs-ng. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.7% (higher than 54% of all known vulnerabilities).

Severity (CVSS 3.1)4.3Medium
Exploit odds (30 days)0.7%top 46.1% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

A vulnerability was found in quickjs-ng QuickJS up to 0.8.0. It has been declared as problematic. Affected by this vulnerability is the function JS_GetRuntime of the file quickjs.c of the component qjs. The manipulation leads to stack-based buffer overflow. The attack can be launched remotely. Upgrading to version 0.9.0 is able to address this issue. The patch is named 99c02eb45170775a9a679c32b45dd4000ea67aff. It is recommended to upgrade the affected component.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Debian:13quickjsno fix listedDEBIAN-CVE-2024-13903
Debian:14quickjsno fix listedDEBIAN-CVE-2024-13903

Affected products (as reported)

VendorProductVersions
quickjs-ng QuickJS 0.10.20.30.40.50.60.70.8

Weakness: CWE-121, CWE-119 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:L

References