Vulnerability · Published Jan 28, 2025 · Assigned by Wordfence
CVE-2024-13509WS Form LITE and PRO <= 1.10.13 - Unauthenticated Stored Cross-Site Scripting
High 7.2
In plain English
A high-severity cross-site scripting in WS Form LITE – Drag & Drop Contact Form Builder from westguard. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.4% (higher than 31% of all known vulnerabilities).
Official description
The WS Form LITE and PRO plugins for WordPress are vulnerable to Stored Cross-Site Scripting via the url parameter in all versions up to, and including, 1.10.13 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. NOTE: This vulnerability is partially fixed in 1.10.13 and completely fixed in 1.10.14.
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| westguard | WS Form LITE – Drag & Drop Contact Form Builder | 0 – through 1.10.13 |
| WS Form | WS Form Pro | 0 – through 1.10.13 |
Weakness: CWE-79 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:L/I:L/A:N