Vulnerability · Published Feb 8, 2024 · Assigned by HashiCorp
CVE-2024-1329Nomad Vulnerable to Arbitrary Write Through Symlink Attack
High 7.7
In plain English
A high-severity security flaw in Nomad from HashiCorp. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.6% (higher than 50% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Severity (CVSS 3.1)7.7High
Exploit odds (30 days)0.6%top 50.3% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known
Official description
HashiCorp Nomad and Nomad Enterprise 1.5.13 up to 1.6.6, and 1.7.3 template renderer is vulnerable to arbitrary file write on the host as the Nomad client user through symlink attacks. This vulnerability, CVE-2024-1329, is fixed in Nomad 1.7.4, 1.6.7, and 1.5.14.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Go | github.com/hashicorp/nomad | 1.7.4 | GHSA-c866-8gpw-p3mv |
| Go | github.com/hashicorp/nomad | 1.5.14 | GHSA-c866-8gpw-p3mv |
| Go | github.com/hashicorp/nomad | 1.6.7 | GHSA-c866-8gpw-p3mv |
| Go | github.com/hashicorp/nomad | 1.5.14, 1.6.7, 1.7.4 | GO-2024-2538 |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| HashiCorp | Nomad | 0 – through 1.5.130 – through 1.6.60 – through 1.7.3 |
| HashiCorp | Nomad Enterprise | 0 – through 1.5.130 – through 1.6.60 – through 1.7.3 |
Weakness: CWE-59 · Vector: CVSS:3.1/AV:N/AC:H/PR:H/UI:N/S:C/C:N/I:H/A:H