Vulnerability · Published Mar 20, 2025 · Assigned by @huntr_ai
CVE-2024-12911SQL Injection in run-llama/llama_index
High 7.1
In plain English
A high-severity SQL injection in run-llama/llama_index from run-llama. Proof-of-concept exploit code is public. The chance it is exploited in the next 30 days is estimated at 0.5% (higher than 44% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
A vulnerability in the `default_jsonalyzer` function of the `JSONalyzeQueryEngine` in the run-llama/llama_index repository allows for SQL injection via prompt injection. This can lead to arbitrary file creation and Denial-of-Service (DoS) attacks. The vulnerability affects the latest version and is fixed in version 0.5.1.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| PyPI | llama-index | 0.12.3 | GHSA-jmgm-gx32-vp4w |
| PyPI | llama-index | 0.12.3 | PYSEC-2026-1555 |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| run-llama | run-llama/llama_index | unspecified – before 0.5.1 |
Weakness: CWE-89 · Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:L/A:H