Vulnerability · Published Dec 20, 2024 · Assigned by HashiCorp

CVE-2024-12678Nomad Allocations Vulnerable To Privilege Escalation Within A Namespace Using Unredacted Workload Identity Tokens

Medium 6.5

In plain English

A medium-severity security flaw in Nomad from HashiCorp. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.5% (higher than 45% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)6.5Medium
Exploit odds (30 days)0.5%top 55.1% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

Nomad Community and Nomad Enterprise ("Nomad") allocations are vulnerable to privilege escalation within a namespace through unredacted workload identity tokens. This vulnerability, identified as CVE-2024-12678, is fixed in Nomad Community Edition 1.9.4 and Nomad Enterprise 1.9.4, 1.8.8, and 1.7.16.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Gogithub.com/hashicorp/nomad1.9.4GHSA-hr68-hvgv-xxqf
Gogithub.com/hashicorp/nomad1.9.4GO-2024-3354

Affected products (as reported)

VendorProductVersions
HashiCorp Nomad 1.4.0 – before 1.9.4
HashiCorp Nomad Enterprise 1.4.0 – before 1.9.4

Weakness: CWE-266 · Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N

References