Vulnerability · Published Feb 12, 2025 · Assigned by Wordfence
CVE-2024-12296Apus Framework <= 2.4 - Authenticated (Subscriber+) Arbitrary Options Update in import_page_options
High 8.8
In plain English
A high-severity missing authorization in Apus Framework from ApusTheme. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.5% (higher than 44% of all known vulnerabilities).
Official description
The Apus Framework plugin for WordPress is vulnerable to unauthorized modification of data that can lead to privilege escalation due to a missing capability check on the 'import_page_options' function in all versions up to, and including, 2.4. This makes it possible for authenticated attackers, with Subscriber-level access and above, to update arbitrary options on the WordPress site. This can be leveraged to update the default role for registration to administrator and enable user registration for attackers to gain administrative user access to a vulnerable site. NOTE: This vulnerability was partially fixed in version 2.4.
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| ApusTheme | Apus Framework | 0 – through 2.4 |
Weakness: CWE-862 · Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H