Vulnerability · Published Feb 12, 2025 · Assigned by Wordfence
CVE-2024-12213WP Job Board Pro < 1.2.85 - Unauthenticated Privilege Escalation via process_register
Critical 9.8
In plain English
A critical-severity security flaw in WP Job Board Pro from http://apusthemes.com/. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.7% (higher than 52% of all known vulnerabilities).
Official description
The WP Job Board Pro plugin for WordPress is vulnerable to privilege escalation in all versions up to 2.3.16. This is due to the plugin allowing a user to supply the 'role' field when registering. This makes it possible for unauthenticated attackers to register as an administrator on vulnerable sites. Please note that this may have been patched sooner, however, the oldest available version for us to confirm this is patched in was 1.2.85.
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| http://apusthemes.com/ | WP Job Board Pro | 0 – before 1.2.85 |
Weakness: CWE-266 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H