Vulnerability · Published Apr 25, 2025 · Assigned by Wordfence
CVE-2024-11917JobSearch WP Job Board <= 2.9.2 - Authentication Bypass via Social Logins
High 8.1
In plain English
A high-severity improper authentication in JobSearch WP Job Board from eyecix. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.5% (higher than 45% of all known vulnerabilities).
Official description
The JobSearch WP Job Board plugin for WordPress is vulnerable to authentication bypass in all versions up to, and including, 2.9.2. This is due to improper configurations in the 'jobsearch_xing_response_data_callback', 'set_access_tokes', and 'google_callback' functions. This makes it possible for unauthenticated attackers to log in as the first connected Xing user, or any connected Xing user if the Xing id is known. It is also possible for unauthenticated attackers to log in as the first connected Google user if the user has logged in, without subsequently logging out, in thirty days. The vulnerability was partially patched in version 2.8.4.
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| eyecix | JobSearch WP Job Board | 0 – through 2.9.2 |
Weakness: CWE-287 · Vector: CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H