Vulnerability · Published Dec 14, 2024 · Assigned by Wordfence
CVE-2024-11888IDer Login for WordPress <= 2.1 - Authenticated (Contributor+) Stored Cross-Site Scripting
Medium 6.4
In plain English
A medium-severity cross-site scripting in IDer Login for WordPress from ider. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.3% (higher than 28% of all known vulnerabilities).
Official description
The IDer Login for WordPress plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the plugin's 'ider_login_button' shortcode in all versions up to, and including, 2.1 due to insufficient input sanitization and output escaping on user supplied attributes. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. This affects version 2.1, but was also patched in version 2.1 - a new version was not released with the patch.
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| ider | IDer Login for WordPress | 0 – through 2.1 |
Weakness: CWE-79 · Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N
References
- https://www.wordfence.com/threat-intel/vulnerabilities/id/de602cf8-cc02-4459-aa23-5d8236048bca?source=cve
- https://plugins.trac.wordpress.org/browser/ider-login/trunk/includes/IDER_Shortcodes.php#L49
- https://wordpress.org/plugins/ider-login
- https://plugins.trac.wordpress.org/changeset/3279435/ider-login/trunk/includes/IDER_Shortcodes.php