Vulnerability · Published Nov 23, 2024 · Assigned by Wordfence
CVE-2024-11426AutoListicle: Automatically Update Numbered List Articles <= 1.2.3 - Authenticated (Contributor+) Stored Cross-Site Scripting
Medium 6.4
In plain English
A medium-severity cross-site scripting in AutoListicle: Automatically Update Numbered List Articles from someguy9. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.4% (higher than 37% of all known vulnerabilities).
Official description
The AutoListicle: Automatically Update Numbered List Articles plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the plugin's 'auto-list-number' shortcode in all versions up to, and including, 1.2.3 due to insufficient input sanitization and output escaping on user supplied attributes. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| someguy9 | AutoListicle: Automatically Update Numbered List Articles | 0 – through 1.2.3 |
Weakness: CWE-79 · Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N
References
- https://www.wordfence.com/threat-intel/vulnerabilities/id/e75313c5-dbc9-4a33-898e-47d8fd299a42?source=cve
- https://plugins.trac.wordpress.org/browser/autolisticle-automatically-update-numbered-list-articles/trunk/autolisticle.php#L62
- https://plugins.trac.wordpress.org/changeset?sfp_email=&sfph_mail=&reponame=&old=3194263%40autolisticle-automatically-update-numbered-list-articles&new=3194263%40autolisticle-automatically-update-numbered-list-articles&sfp_email=&sfph_mail=