Vulnerability · Published Mar 20, 2025 · Assigned by @huntr_ai
CVE-2024-10721Store XSS in phpipam/phpipam
Low 3.5
In plain English
A low-severity cross-site scripting in phpipam/phpipam from phpipam. Proof-of-concept exploit code is public. The chance it is exploited in the next 30 days is estimated at 0.3% (higher than 29% of all known vulnerabilities).
Official description
A stored cross-site scripting (XSS) vulnerability was discovered in phpipam/phpipam version 1.5.2. This vulnerability allows an attacker to inject malicious scripts into the application, which can be executed in the context of other users who view the affected page. The issue occurs in the circuits options page (https://demo.phpipam.net/tools/circuits/options/). An attacker can exploit this vulnerability to steal cookies, gain unauthorized access to user accounts, or redirect users to malicious websites. The vulnerability has been fixed in version 1.7.0.
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| phpipam | phpipam/phpipam | unspecified – before 1.7.0 |
Weakness: CWE-79 · Vector: CVSS:3.0/AV:N/AC:L/PR:L/UI:R/S:U/C:L/I:N/A:N