Vulnerability · Published Mar 20, 2025 · Assigned by @huntr_ai
CVE-2024-10718Cookie without Secure attribute in phpipam/phpipam
Medium 5.3
In plain English
A medium-severity security flaw in phpipam/phpipam from phpipam. Proof-of-concept exploit code is public. The chance it is exploited in the next 30 days is estimated at 0.3% (higher than 27% of all known vulnerabilities).
Severity (CVSS 3.0)5.3Medium
Exploit odds (30 days)0.3%top 72.7% of all CVEs
Exploited in the wildNo reportsCISA SSVC: poc
Attack toolingNoneno public tooling known
Official description
In phpipam/phpipam version 1.5.1, the Secure attribute for sensitive cookies in HTTPS sessions is not set. This could cause the user agent to send those cookies in plaintext over an HTTP session, potentially exposing sensitive information. The issue is fixed in version 1.7.0.
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| phpipam | phpipam/phpipam | unspecified – before 1.7.0 |
Weakness: CWE-614 · Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N