Vulnerability · Published Nov 22, 2024 · Assigned by Wordfence
CVE-2024-10666Easy Twitter Feed – Twitter feeds plugin for WP <= 1.2.6 - Authenticated (Contributor+) Post Exposure
Medium 4.3
In plain English
A medium-severity authorization bypass via user-controlled key in Feeds for Twitter – Embed Social Media Posts with Live Updates from bplugins. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.4% (higher than 39% of all known vulnerabilities).
Official description
The Easy Twitter Feed – Twitter feeds plugin for WP plugin for WordPress is vulnerable to Information Exposure in all versions up to, and including, 1.2.6 via the [etf] shortcode. This makes it possible for authenticated attackers, with Contributor-level access and above, to extract data from password protected, private, or draft posts that they should not have access to.
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| bplugins | Feeds for Twitter – Embed Social Media Posts with Live Updates | 0 – through 1.2.6 |
Weakness: CWE-639 · Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N
References
- https://www.wordfence.com/threat-intel/vulnerabilities/id/d9cd3168-3261-4e36-8fbe-2058cd821937?source=cve
- https://wordpress.org/plugins/easy-twitter-feeds/
- https://plugins.trac.wordpress.org/changeset?sfp_email=&sfph_mail=&reponame=&old=3206719%40easy-twitter-feeds&new=3206719%40easy-twitter-feeds&sfp_email=&sfph_mail=