Vulnerability · Published Dec 12, 2024 · Assigned by Wordfence

CVE-2024-10124Vayu Blocks – Gutenberg Blocks for WordPress & WooCommerce <= 1.1.1 - Missing Authorization to Unauthenticated Arbitrary Plugin Installation/Activation

Critical 9.8

In plain English

A critical-severity improper access control in Vayu Blocks – Website Builder for the Block Editor from themehunk. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 32.7% (higher than 98% of all known vulnerabilities). Ready-made attack tooling exists: public proof-of-concept code.

Severity (CVSS 3.1)9.8Critical
Exploit odds (30 days)32.7%top 1.6% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack tooling1Public PoC

Official description

The Vayu Blocks – Gutenberg Blocks for WordPress & WooCommerce plugin for WordPress is vulnerable to unauthorized arbitrary plugin installation and activation due to a missing capability check on the tp_install() function in all versions up to, and including, 1.1.1. This makes it possible for unauthenticated attackers to install and activate arbitrary plugins which can be leveraged to achieve remote code execution if another vulnerable plugin is installed and activated. This vulnerability was partially patched in version 1.1.1.

Affected products (as reported)

VendorProductVersions
themehunk Vayu Blocks – Website Builder for the Block Editor 0 – through 1.1.1

Weakness: CWE-284 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

References