Vulnerability · Published Dec 29, 2023 · Assigned by VulDB

CVE-2023-7158MicroPython objslice.c slice_indices heap-based overflow

High 7.3

In plain English

A high-severity heap buffer overflow in MicroPython. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 1.2% (higher than 69% of all known vulnerabilities).

Severity (CVSS 3.1)7.3High
Exploit odds (30 days)1.2%top 31.0% of all CVEs
Exploited in the wildNo reportsnot in CISA KEV
Attack toolingNoneno public tooling known

Official description

A vulnerability was found in MicroPython up to 1.21.0. It has been classified as critical. Affected is the function slice_indices of the file objslice.c. The manipulation leads to heap-based buffer overflow. It is possible to launch the attack remotely. The exploit has been disclosed to the public and may be used. Upgrading to version 1.22.0 is able to address this issue. It is recommended to upgrade the affected component. The identifier of this vulnerability is VDB-249180.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Ubuntu:22.04:LTSgiacno fix listedUBUNTU-CVE-2023-7158
Ubuntu:24.04:LTSgiacno fix listedUBUNTU-CVE-2023-7158
Ubuntu:25.10giacno fix listedUBUNTU-CVE-2023-7158
Ubuntu:26.04:LTSgiacno fix listedUBUNTU-CVE-2023-7158
Ubuntu:26.10giacno fix listedUBUNTU-CVE-2023-7158

Affected products (as reported)

VendorProductVersions
n/a MicroPython 1.13.01.14.01.15.01.16.01.17.01.18.01.19.01.20.0

Weakness: CWE-122 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L

References