Vulnerability · Published Dec 16, 2023 · Assigned by VulDB
CVE-2023-6852kalcaddle KodExplorer app.php server-side request forgery
Medium 6.3
In plain English
A medium-severity server-side request forgery in KodExplorer from kalcaddle. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.8% (higher than 56% of all known vulnerabilities).
Official description
A vulnerability classified as critical has been found in kalcaddle KodExplorer up to 4.51.03. Affected is an unknown function of the file plugins/webodf/app.php. The manipulation leads to server-side request forgery. It is possible to launch the attack remotely. The exploit has been disclosed to the public and may be used. Upgrading to version 4.52.01 is able to address this issue. The name of the patch is 5cf233f7556b442100cf67b5e92d57ceabb126c6. It is recommended to upgrade the affected component. The identifier of this vulnerability is VDB-248220.
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| kalcaddle | KodExplorer | 4.51.03 |
Weakness: CWE-918 · Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:L
References
- https://vuldb.com/?id.248220 vdb-entry, technical-description
- https://vuldb.com/?ctiid.248220 signature, permissions-required
- https://note.zhaoj.in/share/P6lQNyqQn3zY broken-link, exploit
- https://github.com/kalcaddle/KodExplorer/commit/5cf233f7556b442100cf67b5e92d57ceabb126c6 patch
- https://github.com/kalcaddle/KodExplorer/releases/tag/4.52.01 patch