Vulnerability · Published Nov 2, 2023 · Assigned by VulDB
CVE-2023-5917phpBB Smiley Pack acp_icons.php main cross site scripting
Low 2.4
In plain English
A low-severity cross-site scripting in phpBB. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.6% (higher than 50% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
A vulnerability, which was classified as problematic, has been found in phpBB up to 3.3.10. This issue affects the function main of the file phpBB/includes/acp/acp_icons.php of the component Smiley Pack Handler. The manipulation of the argument pak leads to cross site scripting. The attack may be initiated remotely. Upgrading to version 3.3.11 is able to address this issue. The patch is named ccf6e6c255d38692d72fcb613b113e6eaa240aac. It is recommended to upgrade the affected component. The associated identifier of this vulnerability is VDB-244307.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Packagist | phpbb/phpbb | 3.3.11 | GHSA-gmx8-8rff-qv6q |
Affected products (as reported)
Weakness: CWE-79 · Vector: CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:U/C:N/I:L/A:N
References
- https://vuldb.com/?id.244307 vdb-entry, technical-description
- https://vuldb.com/?ctiid.244307 signature, permissions-required
- https://www.phpbb.com/community/viewtopic.php?t=2646991 related
- https://github.com/phpbb/phpbb/commit/ccf6e6c255d38692d72fcb613b113e6eaa240aac patch
- https://github.com/phpbb/phpbb/releases/tag/release-3.3.11 patch
- https://www.phpbb.com/ product