Vulnerability · Published Dec 27, 2023 · Assigned by GitHub_M
CVE-2023-52077External apps using tokens issued by administrators and moderators can call admin APIs
High 8.9
In plain English
A high-severity incorrect authorization in nexkey from nexryai. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.7% (higher than 53% of all known vulnerabilities).
Official description
Nexkey is a lightweight fork of Misskey v12 optimized for small to medium size servers. Prior to 12.23Q4.5, Nexkey allows external apps using tokens issued by administrators and moderators to call admin APIs. This allows malicious third-party apps to perform operations such as updating server settings, as well as compromise object storage and email server credentials. This issue has been patched in 12.23Q4.5.
Affected products (as reported)
Weakness: CWE-863 · Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:H/I:H/A:L
References
- https://github.com/nexryai/nexkey/security/advisories/GHSA-pjj7-7hcj-9cpc x_refsource_CONFIRM
- https://github.com/mei23/misskey-v12/commit/78173e376f14fcc1987b02196f5538bf5b18225c x_refsource_MISC
- https://github.com/misskey-dev/misskey/commit/5150053275594278e9eb23e72d98b16593c4c230 x_refsource_MISC
- https://github.com/nexryai/nexkey/commit/a4e4c9c47c5f84ec7ccd309bde59d4ae5d7e5a98 x_refsource_MISC