Vulnerability · Published Feb 7, 2024 · Assigned by apache
CVE-2023-51437Apache Pulsar: Timing attack in SASL token signature verification
High 7.4
In plain English
A high-severity security flaw in Apache Pulsar from Apache Software Foundation. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.8% (higher than 56% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
Observable timing discrepancy vulnerability in Apache Pulsar SASL Authentication Provider can allow an attacker to forge a SASL Role Token that will pass signature verification. Users are recommended to upgrade to version 2.11.3, 3.0.2, or 3.1.1 which fixes the issue. Users should also consider updating the configured secret in the `saslJaasServerRoleTokenSignerSecretPath` file. Any component matching an above version running the SASL Authentication Provider is affected. That includes the Pulsar Broker, Proxy, Websocket Proxy, or Function Worker. 2.11 Pulsar users should upgrade to at least 2.11.3. 3.0 Pulsar users should upgrade to at least 3.0.2. 3.1 Pulsar users should upgrade to at least 3.1.1. Any users running Pulsar 2.8, 2.9, 2.10, and earlier should upgrade to one of the above patched versions. For additional details on this attack vector, please refer to https://codahale.com/a-lesson-in-timing-attacks/ .
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Maven | org.apache.pulsar:pulsar-broker-auth-sasl | 2.11.3 | GHSA-c57v-4vg5-cm2x |
| Maven | org.apache.pulsar:pulsar-broker-auth-sasl | 3.0.2 | GHSA-c57v-4vg5-cm2x |
| Maven | org.apache.pulsar:pulsar-broker-auth-sasl | 3.1.1 | GHSA-c57v-4vg5-cm2x |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| Apache Software Foundation | Apache Pulsar | 0 – through 2.10.52.11.0 – through 2.11.23.0.0 – through 3.0.13.1.0 |
Weakness: CWE-203 · Vector: CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:N