Vulnerability · Published Dec 21, 2023 · Assigned by apache
CVE-2023-50783Apache Airflow: Improper access control vulnerability on the "varimport" endpoint
Medium 6.5
In plain English
A medium-severity improper access control in Apache Airflow from Apache Software Foundation. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 1.4% (higher than 72% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
Apache Airflow, versions before 2.8.0, is affected by a vulnerability that allows an authenticated user without the variable edit permission, to update a variable. This flaw compromises the integrity of variable management, potentially leading to unauthorized data modification. Users are recommended to upgrade to 2.8.0, which fixes this issue
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| PyPI | apache-airflow | 2.8.0 | GHSA-5938-79hg-xh3q |
| PyPI | apache-airflow | 2.8.0 | PYSEC-2023-267 |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| Apache Software Foundation | Apache Airflow | 0 – before 2.8.0 |
Weakness: CWE-284