Vulnerability · Published Dec 22, 2023 · Assigned by GitHub_M
CVE-2023-50730Grackle has StackOverflowError in GraphQL query processing
High 7.5
In plain English
A high-severity uncontrolled resource consumption in grackle from typelevel. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.8% (higher than 58% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
Grackle is a GraphQL server written in functional Scala, built on the Typelevel stack. The GraphQL specification requires that GraphQL fragments must not form cycles, either directly or indirectly. Prior to Grackle version 0.18.0, that requirement wasn't checked, and queries with cyclic fragments would have been accepted for type checking and compilation. The attempted compilation of such fragments would result in a JVM `StackOverflowError` being thrown. Some knowledge of an applications GraphQL schema would be required to construct such a query, however no knowledge of any application-specific performance or other behavioural characteristics would be needed. Grackle uses the cats-parse library for parsing GraphQL queries. Prior to version 0.18.0, Grackle made use of the cats-parse `recursive` operator. However, `recursive` is not currently stack safe. `recursive` was used in three places in the parser: nested selection sets, nested input values (lists and objects), and nested list type declarations. Consequently, queries with deeply nested selection sets, input values or list types could be constructed which exploited this, causing a JVM `StackOverflowException` to be thrown during parsing. Because this happens very early in query processing, no specific knowledge of an applications GraphQL schema would be required to construct such a query. The possibility of small queries resulting in stack overflow is a potential denial of service vulnerability. This potentially affects all applications using Grackle which have untrusted users. Both stack overflow issues have been resolved in the v0.18.0 release of Grackle. As a workaround, users could interpose a sanitizing layer in between untrusted input and Grackle query processing.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Maven | edu.gemini:gsp-graphql-core_2.13 | no fix listed | GHSA-g56x-7j6w-g8r8 |
| Maven | edu.gemini:gsp-graphql-core_3 | no fix listed | GHSA-g56x-7j6w-g8r8 |
| Maven | edu.gemini:gsp-graphql-core_native0.4_2.13 | no fix listed | GHSA-g56x-7j6w-g8r8 |
| Maven | edu.gemini:gsp-graphql-core_native0.4_3 | no fix listed | GHSA-g56x-7j6w-g8r8 |
| Maven | edu.gemini:gsp-graphql-core_sjs1_2.13 | no fix listed | GHSA-g56x-7j6w-g8r8 |
| Maven | edu.gemini:gsp-graphql-core_sjs1_3 | no fix listed | GHSA-g56x-7j6w-g8r8 |
| Maven | org.typelevel:grackle-core_2.13 | 0.18.0 | GHSA-g56x-7j6w-g8r8 |
| Maven | org.typelevel:grackle-core_3 | 0.18.0 | GHSA-g56x-7j6w-g8r8 |
| Maven | org.typelevel:grackle-core_native0.4_2.13 | 0.18.0 | GHSA-g56x-7j6w-g8r8 |
| Maven | org.typelevel:grackle-core_native0.4_3 | 0.18.0 | GHSA-g56x-7j6w-g8r8 |
| Maven | org.typelevel:grackle-core_sjs1_2.13 | 0.18.0 | GHSA-g56x-7j6w-g8r8 |
| Maven | org.typelevel:grackle-core_sjs1_3 | 0.18.0 | GHSA-g56x-7j6w-g8r8 |
Affected products (as reported)
Weakness: CWE-400, CWE-770 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H