Vulnerability · Published Dec 22, 2023 · Assigned by GitHub_M

CVE-2023-50727Resque vulnerable to reflected XSS in Queue Endpoint

Medium 6.3

In plain English

A medium-severity cross-site scripting in resque from resque. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.5% (higher than 44% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)6.3Medium
Exploit odds (30 days)0.5%top 56.0% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

Resque is a Redis-backed Ruby library for creating background jobs, placing them on multiple queues, and processing them later. Reflected XSS issue occurs when /queues is appended with /"><svg%20onload=alert(domain)>. This issue has been patched in version 2.6.0.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
RubyGemsresque2.6.0GHSA-r9mq-m72x-257g

Affected products (as reported)

VendorProductVersions
resque resque < 2.6.0

Weakness: CWE-79 · Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:L/I:H/A:N

References