Vulnerability · Published Dec 22, 2023 · Assigned by GitHub_M

CVE-2023-50725Resque vulnerable to reflected XSS in resque-web failed and queues lists

Medium 6.3

In plain English

A medium-severity cross-site scripting in resque from resque. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.5% (higher than 45% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)6.3Medium
Exploit odds (30 days)0.5%top 55.3% of all CVEs
Exploited in the wildNo reportsnot in CISA KEV
Attack toolingNoneno public tooling known

Official description

Resque is a Redis-backed Ruby library for creating background jobs, placing them on multiple queues, and processing them later. The following paths in resque-web have been found to be vulnerable to reflected XSS: "/failed/?class=<script>alert(document.cookie)</script>" and "/queues/><img src=a onerror=alert(document.cookie)>". This issue has been patched in version 2.2.1.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
RubyGemsresque2.2.1GHSA-gc3j-vvwf-4rp8

Affected products (as reported)

VendorProductVersions
resque resque < 2.2.1

Weakness: CWE-79 · Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:L/I:H/A:N

References