Vulnerability · Published Dec 21, 2023 · Assigned by GitHub_M
CVE-2023-50724Resque vulnerable to reflected cross site scripting through pathname
Medium 6.3
In plain English
A medium-severity cross-site scripting in resque from resque. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.5% (higher than 42% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
Resque (pronounced like "rescue") is a Redis-backed library for creating background jobs, placing those jobs on multiple queues, and processing them later. resque-web in resque versions before 2.1.0 are vulnerable to reflected XSS through the current_queue parameter in the path of the queues endpoint. This issue has been patched in version 2.1.0.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| RubyGems | resque | 2.1.0 | GHSA-r8xx-8vm8-x6wj |
Affected products (as reported)
Weakness: CWE-79 · Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:L/I:H/A:N
References
- https://github.com/resque/resque/security/advisories/GHSA-r8xx-8vm8-x6wj x_refsource_CONFIRM
- https://github.com/resque/resque/issues/1679 x_refsource_MISC
- https://github.com/resque/resque/pull/1687 x_refsource_MISC