Vulnerability · Published Feb 9, 2024 · Assigned by apache

CVE-2023-50386Apache Solr: Backup/Restore APIs allow for deployment of executables in malicious ConfigSets

High 8.8

In plain English

A high-severity unrestricted file upload in Apache Solr from Apache Software Foundation. Proof-of-concept exploit code is public. The chance it is exploited in the next 30 days is estimated at 83.7% (higher than 99.7% of all known vulnerabilities). Ready-made attack tooling exists: Metasploit, public proof-of-concept code. Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)8.8High
Exploit odds (30 days)83.7%top 0.3% of all CVEs
Exploited in the wildNo reportsCISA SSVC: poc
Attack tooling2Metasploit, Public PoC

Official description

Improper Control of Dynamically-Managed Code Resources, Unrestricted Upload of File with Dangerous Type, Inclusion of Functionality from Untrusted Control Sphere vulnerability in Apache Solr.This issue affects Apache Solr: from 6.0.0 through 8.11.2, from 9.0.0 before 9.4.1. In the affected versions, Solr ConfigSets accepted Java jar and class files to be uploaded through the ConfigSets API. When backing up Solr Collections, these configSet files would be saved to disk when using the LocalFileSystemRepository (the default for backups). If the backup was saved to a directory that Solr uses in its ClassPath/ClassLoaders, then the jar and class files would be available to use with any ConfigSet, trusted or untrusted. When Solr is run in a secure way (Authorization enabled), as is strongly suggested, this vulnerability is limited to extending the Backup permissions with the ability to add libraries. Users are recommended to upgrade to version 8.11.3 or 9.4.1, which fix the issue. In these versions, the following protections have been added: * Users are no longer able to upload files to a configSet that could be executed via a Java ClassLoader. * The Backup API restricts saving backups to directories that are used in the ClassLoader.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Debian:12lucene-solr3.6.2+dfsg-23DEBIAN-CVE-2023-50386
Debian:13lucene-solr3.6.2+dfsg-23DEBIAN-CVE-2023-50386
Debian:14lucene-solr3.6.2+dfsg-23DEBIAN-CVE-2023-50386
Mavenorg.apache.solr:solr-core8.11.3GHSA-37vr-vmg4-jwpw
Mavenorg.apache.solr:solr-core9.4.1GHSA-37vr-vmg4-jwpw
Ubuntu:22.04:LTSlucene-solr3.6.2+dfsg-24UBUNTU-CVE-2023-50386

Affected products (as reported)

VendorProductVersions
Apache Software Foundation Apache Solr 6.0.0 – through 8.11.29.0.0 – before 9.4.1

Weakness: CWE-434, CWE-913 · Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

References