Vulnerability · Published Mar 1, 2024 · Assigned by apache
CVE-2023-50378Apache Ambari: Various XSS problems
Medium 6.1
In plain English
A medium-severity cross-site scripting in Apache Ambari from Apache Software Foundation. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 1.2% (higher than 69% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
Lack of proper input validation and constraint enforcement in Apache Ambari prior to 2.7.8 Impact : As it will be stored XSS, Could be exploited to perform unauthorized actions, varying from data access to session hijacking and delivering malicious payloads. Users are recommended to upgrade to version 2.7.8 which fixes this issue.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Maven | org.apache.ambari:ambari | 2.7.8 | GHSA-9q6v-rxmw-g3gh |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| Apache Software Foundation | Apache Ambari | 2.7.0 – through 2.7.7 |
Weakness: CWE-79 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
References
- https://lists.apache.org/thread/6hn0thq743vz9gh283s2d87wz8tqh37c vendor-advisory
- http://www.openwall.com/lists/oss-security/2024/03/01/5 x_transferred