Vulnerability · Published Feb 9, 2024 · Assigned by apache

CVE-2023-50298Apache Solr: Solr can expose ZooKeeper credentials via Streaming Expressions

High 7.5

In plain English

A high-severity information exposure in Apache Solr from Apache Software Foundation. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 1.6% (higher than 75% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)7.5High
Exploit odds (30 days)1.6%top 24.6% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

Exposure of Sensitive Information to an Unauthorized Actor vulnerability in Apache Solr.This issue affects Apache Solr: from 6.0.0 through 8.11.2, from 9.0.0 before 9.4.1. Solr Streaming Expressions allows users to extract data from other Solr Clouds, using a "zkHost" parameter. When original SolrCloud is setup to use ZooKeeper credentials and ACLs, they will be sent to whatever "zkHost" the user provides. An attacker could setup a server to mock ZooKeeper, that accepts ZooKeeper requests with credentials and ACLs and extracts the sensitive information, then send a streaming expression using the mock server's address in "zkHost". Streaming Expressions are exposed via the "/streaming" handler, with "read" permissions. Users are recommended to upgrade to version 8.11.3 or 9.4.1, which fix the issue. From these versions on, only zkHost values that have the same server address (regardless of chroot), will use the given ZooKeeper credentials and ACLs when connecting.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Debian:12lucene-solr3.6.2+dfsg-23DEBIAN-CVE-2023-50298
Debian:13lucene-solr3.6.2+dfsg-23DEBIAN-CVE-2023-50298
Debian:14lucene-solr3.6.2+dfsg-23DEBIAN-CVE-2023-50298
Mavenorg.apache.solr:solr-solrj9.4.1GHSA-xrj7-x7gp-wwqr
Mavenorg.apache.solr:solr-solrj8.11.3GHSA-xrj7-x7gp-wwqr
Mavenorg.apache.solr:solr-solrj-streaming9.4.1GHSA-xrj7-x7gp-wwqr
Mavenorg.apache.solr:solr-solrj-streaming8.11.3GHSA-xrj7-x7gp-wwqr
Ubuntu:22.04:LTSlucene-solr3.6.2+dfsg-24UBUNTU-CVE-2023-50298

Affected products (as reported)

VendorProductVersions
Apache Software Foundation Apache Solr 6.0.0 – through 8.11.29.0.0 – before 9.4.1

Weakness: CWE-200, CWE-922 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N

References