Vulnerability · Published Feb 9, 2024 · Assigned by apache

CVE-2023-50292Apache Solr: Solr Schema Designer blindly "trusts" all configsets, possibly leading to RCE by unauthenticated users

High 7.5

In plain English

A high-severity incorrect permission assignment in Apache Solr from Apache Software Foundation. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 3.0% (higher than 88% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)7.5High
Exploit odds (30 days)3.0%top 12.5% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

Incorrect Permission Assignment for Critical Resource, Improper Control of Dynamically-Managed Code Resources vulnerability in Apache Solr. This issue affects Apache Solr: from 8.10.0 through 8.11.2, from 9.0.0 before 9.3.0. The Schema Designer was introduced to allow users to more easily configure and test new Schemas and configSets. However, when the feature was created, the "trust" (authentication) of these configSets was not considered. External library loading is only available to configSets that are "trusted" (created by authenticated users), thus non-authenticated users are unable to perform Remote Code Execution. Since the Schema Designer loaded configSets without taking their "trust" into account, configSets that were created by unauthenticated users were allowed to load external libraries when used in the Schema Designer. Users are recommended to upgrade to version 9.3.0, which fixes the issue.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Debian:12lucene-solr3.6.2+dfsg-23DEBIAN-CVE-2023-50292
Debian:13lucene-solr3.6.2+dfsg-23DEBIAN-CVE-2023-50292
Debian:14lucene-solr3.6.2+dfsg-23DEBIAN-CVE-2023-50292
Mavenorg.apache.solr:solr-core9.3.0GHSA-4wxw-42wx-2wfx
Mavenorg.apache.solr:solr-core8.11.3GHSA-4wxw-42wx-2wfx
Ubuntu:22.04:LTSlucene-solr3.6.2+dfsg-24UBUNTU-CVE-2023-50292

Affected products (as reported)

VendorProductVersions
Apache Software Foundation Apache Solr 8.10.0 – through 8.11.29.0.0 – before 9.3.0

Weakness: CWE-732 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N

References