Vulnerability · Published Dec 21, 2023 · Assigned by apache
CVE-2023-49920Apache Airflow: Missing CSRF protection on DAG/trigger
Medium 6.5
In plain English
A medium-severity cross-site request forgery in Apache Airflow from Apache Software Foundation. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 1.0% (higher than 64% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
Apache Airflow, version 2.7.0 through 2.7.3, has a vulnerability that allows an attacker to trigger a DAG in a GET request without CSRF validation. As a result, it was possible for a malicious website opened in the same browser - by the user who also had Airflow UI opened - to trigger the execution of DAGs without the user's consent. Users are advised to upgrade to version 2.8.0 or later which is not affected
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| PyPI | apache-airflow | 2.8.0 | GHSA-6m9r-7wrx-xmr6 |
| PyPI | apache-airflow | 2.8.0b1 | PYSEC-2023-266 |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| Apache Software Foundation | Apache Airflow | 2.7.0 – before 2.8.0 |
Weakness: CWE-352