Vulnerability · Published Dec 19, 2023 · Assigned by apache

CVE-2023-49736Apache Superset: SQL Injection on where_in JINJA macro

Medium 6.5

In plain English

A medium-severity SQL injection in Apache Superset from Apache Software Foundation. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 1.2% (higher than 68% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)6.5Medium
Exploit odds (30 days)1.2%top 32.0% of all CVEs
Exploited in the wildNo reportsnot in CISA KEV
Attack toolingNoneno public tooling known

Official description

A where_in JINJA macro allows users to specify a quote, which combined with a carefully crafted statement would allow for SQL injection in Apache Superset.This issue affects Apache Superset: before 2.1.2, from 3.0.0 before 3.0.2. Users are recommended to upgrade to version 3.0.2, which fixes the issue.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
PyPIapache-superset2.1.3GHSA-jfxj-xf67-x723
PyPIapache-superset3.0.2GHSA-jfxj-xf67-x723
PyPIapache-superset2.1.3, 3.0.2PYSEC-2026-1184

Affected products (as reported)

VendorProductVersions
Apache Software Foundation Apache Superset 0 – before 2.1.23.0.0 – before 3.0.2

Weakness: CWE-89 · Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:N

References